Jump to content

Recommended Posts

Our Sponsors

Hi all,

 

Hope you are all well.

I have recently purchased a set of Arccos sensors and have tried to pair them to my phone which is a Samsung S20 plus and I just can't get it to work.

 

I then downloaded the app on my partner's phone (iPhone) and they have paired instantly so I'm guessing it's the phone and not the sensors.

 

It's a longshot I know but has anyone had the same problem and if so how have they got over it.

Many thanks

 

Liam

 

  • Like 1
Link to post
Share on other sites

By most account, Arccos on Android is a problem, and my understanding is that Samsung's are notoriously bad with Arccos. I'm an Android guy myself, but I picked up a new-in-box iPhone 6 (for $45!) that is my dedicated Arccos device.

  • Like 2

:callaway-small: Epic Flash Sub Zero, 9°, Aldila Rogue White 70 X
:taylormade-small: M4 3HL 16.5°, Atmos Red 60
:cobra-small: F6 5-6W, 19.5°, Fujikura Motore 6.3
:755178188_TourEdge: CBX 20°, Project X HZRDUS 85 5.5
:Sub70: 699 Pro, Modus3 105, 5–PW
:Sub70: Forged Black 50°, 54°, and 58°
:odyssey-small: Stroke Lab EXO Seven Mini, 34"
:srixon-small: Z-Star XV

Link to post
Share on other sites
On 5/15/2020 at 11:21 AM, GolfSpy MPR said:

By most account, Arccos on Android is a problem, and my understanding is that Samsung's are notoriously bad with Arccos. I'm an Android guy myself, but I picked up a new-in-box iPhone 6 (for $45!) that is my dedicated Arccos device.

As I understand it (and in my experience) the Samsung problem is mostly a battery life issue. I could barely get 18 with my Galaxy S9+, so I now use my 4 year old Huawei without a SIM card and still have 70-ish% after 18. The downside is I don't get real-time weather updates to correct my "plays as" distance.

As for OP's issue? Sorry, I'm no help. The sensors paired with my Samsung quickly and easily.

Driver: :bridgestone-small: Tour B JGR 9.5* Recoil 460ES cut to 45"
3W: :bridgestone-small: Tour B JGR 15* Recoil 460ES
3H, 4H: :bridgestone-small: Tour B JGR 19*, 23* Recoil 780ES
4-PW:  :bridgestone-small: Tour B JGR HF2 Modus3 Tour 105
AW: :mizuno-small:S5 52*
SW: :cleveland-small: 588
LW: :callaway-small: MD3
Putter: :odyssey-small: Stroke Lab Marxman
Bag: :bridgestone-small: Tour B Stand Bag
Ball: :srixon-small: Z-Star
Pushcart: BigMax iQ+

:SuperSpeed: Tester
Starting Driver Speed on PRGR Monitor: 102 mph

Final Driver Speed (end of Level 2): 120 mph

Link to post
Share on other sites
On ‎5‎/‎15‎/‎2020 at 10:21 AM, GolfSpy MPR said:

By most account, Arccos on Android is a problem, and my understanding is that Samsung's are notoriously bad with Arccos. I'm an Android guy myself, but I picked up a new-in-box iPhone 6 (for $45!) that is my dedicated Arccos device.

were u get that iPhone at

 :ping-small:G410 LST 7* W/ UST V2 84-gram S-shaft

 :ping-small:G400 Strength 3 wood 12* W/ UST V2 94-gram S-shaft

 :tour-edge: EXS PRO Hybrid 19* & 22* W/ 6.0 SMOKE 80g

:srixon-small: Z585 5-PW MODUS Tour S-105 / May switch out to S400's in the future

 :cleveland-small:CBX FULL FACE 56* & Smart Sole 4 G/W 50*

 :cleveland-small:Cleveland Classic Collection HB 2 Black Pearl putter

:Snell:MTB-X Yellow

:titelist-small: Bag

:Arccos:

 

 

 

Link to post
Share on other sites
On 5/15/2020 at 11:01 AM, Liam87 said:

Hi all,

 

Hope you are all well.

I have recently purchased a set of Arccos sensors and have tried to pair them to my phone which is a Samsung S20 plus and I just can't get it to work.

 

I then downloaded the app on my partner's phone (iPhone) and they have paired instantly so I'm guessing it's the phone and not the sensors.

 

It's a longshot I know but has anyone had the same problem and if so how have they got over it.

Many thanks

 

Liam

 

I've got an S9+ and it took me quite a while to get my sensors to pair. I ended up going outside when it was very bright and very quiet (just in case) and eventually I got 13 of the 14 to pair. I ended up contacting Arccos for a replacement for the 14th and they sent it out and it paired almost right away. But definitely very finicky. (And FWIW, I basically never get the putter to register during the round. Annoying, but as long as the long shots work reasonably well, I don't mind the little bit of manual entry.)

Driver: :callaway-small: Epic Flash Subzero 9* loft with HZDRUS Smoke stiff
4-wood: :callaway-small: Mavrik Subzero (16.5*) with Aldila Rogue White 130 MSI X
2-hybrid: :taylormade-small: GAPR Lo with stock KBS Hybrid 80g stiff
3i-PW: :ping-small: i210 blue dot, Power Spec, with TT S300 hard stepped
50*, 54*, and 58*: :mizuno-small: blue ion S18 with TT wedge
Putter: :ping-small: Redwood Piper 0*

Ball: :srixon-small: Z STAR XV
Bag: :ping-small: Hoofer (2018) in black/white/copper

Using :Arccos: to keep track of my shots
All clubs RH

Tested:
:wilson_staff_small: D7 Forged 3-PW, KBS Tour-V 110S - Official Review

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...